Posts Tagged ‘SCVMM 2008 R2’

SCVMM 2008 R2 error adding hosts

October 20, 2010

I had a clean install of SCVMM 2008 R2 running as the first VM on a Hyper-V 2008 R2 cluster.
When trying to add the Hyper-V hosts to SCVMM to start managing them, i got an Error (406):

Access has been denied while contacting the server node4.domain.local.

Recommended Action
1. Verify that the specified user account has administrative privileges on node4.domain.local.
2. Verify that DCOM access, launch, and activation permissions are enabled on node4.domain.local for the Administrators group. Use dcomcnfg.exe to modify permissions, and then try the operation again.

Also, SCVMM couldn’t access it’s own library (access denied), which actually was on the same server. Weird.
After trying every possibility concerning user rights and access rights, i decided to reinstall the whole box.
After that, the problem returned. Darn.
Then i remembered that i had manually added a proxy server to the winhttp service, for accessing the microsoft update site.
This because the Microsoft Update Service did not pick up the IE Proxy settings.
The command i used to set it up was:
netsh winhttp set proxy (ip address of proxyserver):(portnumber) bypass-list:""
This way, it would not use the proxy for all local network traffic.
Such as traffic from SCVMM to itself, or to the nodes.
After removing the proxy with “netsh winhttp reset proxy” , i was finally able to successfully add hosts to SCVMM, and the SCVMM server was able to connect to its own library again.
Apparently the “local” bit didn’t really do what it was supposed to….

Advertisements