SCOM 2012 SP1, error 500 Internal Server Error when using Web Console

With a fresh install of SCOM 2012 SP1, the Web Console gave me this error.
I was able to logon to the website, see the list of reports on the left, but when i selected one of the reports (Active Alerts for instance) i got this error 500.
On the server itself i got a more precise error:
HTTP error 500.19 – Internal Server Error
HRESULT: 0x800700b7
The requested page cannot be accessed because the related configuration data for the page is invalid.
There is a duplicate ‘uri’ section defined in file Web.Config

So this pointed me to the file Web.Config, which had a single record of uri, but also this sentence:

“Note, the URI config section is not declared in machine.config for .NET 2.x-3.x, so declaring it explicitly here”

But in IIS 7.5, the Application Pools were all configured to use .NET 4.
So this could very well be the cause of the duplicate uri section.

Solution:
In IIS, i changed the Application Pools in IIS for OperationsManagerMonitoringView to use .NET 2 instead of 4.
AFter that, a recycle of the application pool, en presto, the OperationsManager Web Console was working again.

Advertisements

Tags: ,

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s


%d bloggers like this: