Archive for July, 2012

ESXi 5 installation to SDcard fails; “Could not rebuild bootbank database”

July 23, 2012

Setting: trying to install ESXi 5 on a HP Proliant DL360p Gen8 server, on a 4 GB SDcard installed in the internal SD slot.

During installation, when choosing the disk to install ESXi to, the SD card is shown as HP ILO SD card. Weird.The server doesn’t have the Advanced ILO license, but maybe if it did, this sdcard could also be used for ILO storage? Confusing.
After doublechecking that this the only internal SD slot, we choose to install to this one.

By the way, for the installation we used the latest HP-provided ESXi-5 ISO, currently 5.0 U1 Jun 2012 ESXi HD-USB-SDImgeInstlr (Z7550-00779.iso) (link)

Updated all firmware/bios/drivers to latest version, using HP Smart Update Firmware DVD v 10.10

The problem

After choosing the SDcard as target, the installation process would fail at 51% with the following error:

Image

You understand why i’m not typing out the error code, right 🙂

When researching this error, it seemd to have something to do with not finding a proxy server.

No problem, just yanked all network cables out of the server and restarted the installation.

Now the installation failed again at 51%, but with a different error:

“Could not rebuild bootbank database”

Right…. now what.

Another try then. First took out the SD card and formatted it, then tried again.

Now the following error:

Failed to check for existing filesystem on device

Error: unable to access device, please check your connection to the device

Image

Right, that’s enough. Has to be the disk (sdcard ) then.

The solution

We took out the SD card, and tried to access it in another computer. No dice.

We then inserted a new SD card in the server, and voila, no more errors.

The installation finished flawlessly within minutes.

 

—> Props go to my colleague B-Sting, for his patience in getting to the bottom of this. Pics are his too 🙂  <—